[Lazarus] Keyboard handling messed up in LCL (recent change)

Michael Van Canneyt michael at freepascal.org
Sat Mar 21 11:26:08 CET 2015


I don't know how best to explain this problem.

Platform: Linux, 64 bit PC. GTK

Today, I started a recent lazarus 1.5 on a new PC and started working in it. 
After some time I noticed the m key (on an azerty keyboard) no longer worked in the source editor.
Prior to that I had not touched the M key.

In synedit, The M behaves as a 'ctrl-m' key: a CR (^13) is inserted !
I know the synedit is a bit special. So I decided to test the key in another edit control.

Pressing shift-M works as expected and inserts a capital M.

When typing in the "project options", "title" option edit control, I got double m characters.

So, I then updated lazarus from SVN to todays version and recompiled. The problem persisted.
Then, when typing in any edit box, now I get double letters (a -> aa etc)

as soon as I touch the m key, all input just stops, I can no longer edit anything.
Restarting lazarus allows me to type characters, until I touch the M key outside of synedit.

I had several older lazarus binaries on this machine, so I tried that: there the 'm' key works fine.

The strange thing is, if I go to 'keyboard mappings' 'Find key combination' and press 'Grab key' 
then the key is displayed fine.

The m key works as expected in all other programs:
I am typing this mail on the same machine, and the M key works just fine.

All this makes me pretty confident it is a Lazarus issue, probably trying to handle the
CTRL-M (CR) key in some special (global) way.

Suggestions for fixing this ?


More information about the Lazarus mailing list