[Lazarus] Keyboard handling messed up in LCL (recent change)

Graeme Geldenhuys mailinglists at geldenhuys.co.uk
Sat Mar 21 14:28:30 CET 2015

On 2015-03-21 10:26, Michael Van Canneyt wrote:
> I don't know how best to explain this problem.

Funny you mention this (strange is why I didn't report it). I've also
updated my Lazarus this week and Ctrl+O stopped working - yet in other
programs like Firefox or gEdit it works just fine. Pressing the O key on
its own worked and Alt+O worked. I think the issue is with the Ctrl key.
Because Ctrl+Z was acting as if the Tab key was pressed. This drove me nuts

I was using CentOS 6.6 64-bit and Lazarus IDE compiled with GTK2.

No matter how many times I recompiled the IDE, the problem didn't go
away. I eventually found a work-around and that was to switch my
keyboard layout in Gnome. Toggling between two layouts (Qwerty & Dvorak)
and it corrected itself. If this is going to last, I don't know.

  - Graeme -

fpGUI Toolkit - a cross-platform GUI toolkit using Free Pascal

More information about the Lazarus mailing list