[Lazarus] Default ico handling and recent debugger errors

JuuS JuuS at mykolab.ch
Sat Mar 21 14:32:53 CET 2015

While testing RC1 and 2 I followed the suggestion to open a published
project and see how the release candidates were doing with them.

Upon doing this I got an immediate debugger error, which has been traced
down now (as of last night) with the help of Martin and is fixed.

The problems origins were (and still are to some extent)...weird.

Before a debugger solution was found I could stop the error by simply
removing the "default icon" line from the published project's LPI file,
then no debugger error.

During all the research I could see that while the LPI file had a
"default icon" line, the publishing process did not copy the ico file to
the published diretory.

So there was always a background silent error due to the fact that the
icon file didn't exist, the silent exception (seen when debugging
Lazarus) was on trying to open this nonexisting file.

How this all caused the debugger error is, as I have said, still not
entirely understood.

So it just brings to my mind that even though this error has no effect
in most cases it may be best to either copy the ico file on publishing
the project, or not writing a "default icon" line in LPI, or checking
that the ico file actually does exist and recreating it if not; just in
case it has other effects that will cause other "weird" errors down the

On 03/21/2015 02:04 PM, JuuS wrote:
> What a coincidence!~
> I just wrote a message to board about this...it is ibus.
> go to terminal: type: ibus exit
> Your problems will go away...
> On 03/21/2015 11:26 AM, Michael Van Canneyt wrote:
>> Gentlemen,
>> I don't know how best to explain this problem.
>> Platform: Linux, 64 bit PC. GTK
>> Today, I started a recent lazarus 1.5 on a new PC and started working in
>> it. After some time I noticed the m key (on an azerty keyboard) no
>> longer worked in the source editor.
>> Prior to that I had not touched the M key.
>> In synedit, The M behaves as a 'ctrl-m' key: a CR (^13) is inserted !
>> I know the synedit is a bit special. So I decided to test the key in
>> another edit control.
>> Pressing shift-M works as expected and inserts a capital M.
>> When typing in the "project options", "title" option edit control, I got
>> double m characters.
>> So, I then updated lazarus from SVN to todays version and recompiled.
>> The problem persisted.
>> Then, when typing in any edit box, now I get double letters (a -> aa etc)
>> as soon as I touch the m key, all input just stops, I can no longer edit
>> anything.
>> Restarting lazarus allows me to type characters, until I touch the M key
>> outside of synedit.
>> I had several older lazarus binaries on this machine, so I tried that:
>> there the 'm' key works fine.
>> The strange thing is, if I go to 'keyboard mappings' 'Find key
>> combination' and press 'Grab key' then the key is displayed fine.
>> The m key works as expected in all other programs:
>> I am typing this mail on the same machine, and the M key works just fine.
>> All this makes me pretty confident it is a Lazarus issue, probably
>> trying to handle the
>> CTRL-M (CR) key in some special (global) way.
>> Suggestions for fixing this ?
>> Michael.
>> -- 
>> _______________________________________________
>> Lazarus mailing list
>> Lazarus at lists.lazarus.freepascal.org
>> http://lists.lazarus.freepascal.org/mailman/listinfo/lazarus
> --
> _______________________________________________
> Lazarus mailing list
> Lazarus at lists.lazarus.freepascal.org
> http://lists.lazarus.freepascal.org/mailman/listinfo/lazarus

More information about the Lazarus mailing list