[Lazarus] Trouble [re-]installing fpc from SourceForge (and other sources)

Donald Ziesig donald at ziesig.org
Sun Dec 4 20:32:22 CET 2016

On 12/03/2016 03:56 PM, Mattias Gaertner via Lazarus wrote:
> On Fri, 2 Dec 2016 20:00:56 -0500
> Donald Ziesig via Lazarus <lazarus at lists.lazarus-ide.org> wrote:
>> I have been trying to upgrade to lazarus 1.6.2 on *Linux Mint Sarah*
>> with no success.  After days of failure, I decided to revert to 1.6.0
>> using the .deb files from SourceForge.  Then using Synaptic for 1.6.0.
>> Lastly using apt-get from the command line. In all cases, the
>> installation of *fpc *fails.
>> It used to work till I started this upgrade.
>> All attempts to get fpc working fail, essentially the same way:
>> ┌[ 2001  2.3.0 19:30:33 ~ ]
>> └> fpc
>> The program 'fpc' is currently not installed. You can install it by typing:
>> sudo apt install fp-compiler-3.0.0
> Please try this:
> - uninstall the lazarus package and all fp- packages.
> - update your system
> - download the new lazarus-project_1.6.2 package from our sourceforge
>    site and install it.
> - If your installer did not automatically install the dependencies,
>    install them now
> Mattias

It seems that the apt metadata got corrupted.  fpc was not the only 
package that would not reinstall properly.  I had to reload the entire 
thing and clear the apt cache.  I installed the original fpc and it worked.

I then removed fpc and downloaded lazarus-project_1.6.2.  Lazarus worked 
(even though the installation said that there are 88 packages missing).  
Where can I find out which packages are needed and how to install them?


Don Z.

More information about the Lazarus mailing list