[Lazarus] [SOLVED] Laz 1.6.3 and Frames

Tomáš Emresz tomas.emresz at strankysnadno.cz
Tue Dec 13 20:10:08 CET 2016


yes, but on run, applications hangs. I found, that i have somethink bad 
with my lazarus, because when i place button on frame, in source of my 
frame, there is not button in the class and something else like this. I 
completelly reinstall lazarus and fpc, and after this, i click rescan 
fpc source from lazarus.

Now, it runs ok (and in frame source button is placed).

So this is solved. - Rescan FPC source was - IMHO - the problem.


Dne 13. 12. 2016 v 16:35 Mattias Gaertner via Lazarus napsal(a):
> On Tue, 13 Dec 2016 16:22:18 +0100
> Tomáš Emresz via Lazarus <lazarus at lists.lazarus-ide.org> wrote:
>> Hello,
>> i created stupid application with on form, created new frame, place
>> button on it (in frame source, there is not button shown (as in forms)).
>> Use tframe for place this on main form.
> Do you mean
> -Create Application, save (project1.lpi, unit1.pas)
> -File / New ... / Frame, save (unit2.pas)
> -Drop button on Frame1, (Button1)
> -Drop Frame on Form1 (Frame1_1), Button1 is shown on Form1.
> Run, Form1 is shown with Button1.
> ?
> Mattias

More information about the Lazarus mailing list