[Lazarus] Lazarus IDE compilation error due to "No memory left"

Martin Frb lazarus at mfriebe.de
Mon Sep 12 03:34:45 CEST 2016

On 12/09/2016 02:14, Luiz Americo Pereira Camara wrote:
> When i try to recompile the IDE i'm getting the error below:
> Error: (1026) Compilation raised exception internally
> Fatal: (1009) No memory left
> Error: C:\bin\code\fpcdev\bin\i386-win32\ppc386.exe returned an error 
> exitcode
> I have a decent computer 8 GB ram, core i5 third generation.
> Running windows 10, fpc trunk 32bit, lazarus trunk.
> In the task manager, i get 42% of memory usage (3,3 GB of 7,9GB) 
> having more then 4GB free
32 bit doesnt use more than 4GB, and some goes to the system.
> The problems seems related to number of packages installed (i have 
> 78). Trying to compile in a linux VM with fewer packges runs fine.
> In previous times, i rebooted and the compilation suceeded. Today 
> still not tried.

Switch of smart linking for the IDE.
You can keep the units smartlink-able (for your projects).
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.lazarus-ide.org/pipermail/lazarus/attachments/20160912/a0f4561a/attachment-0001.html>

More information about the Lazarus mailing list