[Lazarus] Installed lazarus-ide in Ubuntu18, cannot install package

Juha Manninen juha.manninen62 at gmail.com
Wed Oct 24 17:54:53 CEST 2018

On Wed, Oct 24, 2018 at 3:21 PM Brian via Lazarus
<lazarus at lists.lazarus-ide.org> wrote:
> I can't speak for why other people won't do it, but before I retired,
> I worked for a division of an extremely large company with a 'managed
> PC' environment, where we were strictly forbidden to install anything
> which could be regarded as beta-test software, and I'm absolutely
> certain that the SVN versions would be regarded in that light.
> *Approved* full releases only, no exceptions! This was in a testing
> laboratory environment, subject to ISO 9002 regulations, and breaking
> the policy was a disciplinary offence.

Yes I know there are such policies.
In case of SVN fixes branches for released Lazarus versions, like
fixes_1_8, the policy leads to having worse code.
A fixes branch has the code from a release + recent bug fixes. It is
better than the release by definition.

On Wed, Oct 24, 2018 at 3:45 PM Brian via Lazarus
<lazarus at lists.lazarus-ide.org> wrote:
> Well, here's an example for you of why people may refuse to use SVN.
> I downloaded the sources via svn and built Lazarus, no problem in that
> step.
> Then I ran V2.0 and started installing some packages I use.
> I got the following error on rebuilding Lazarus, line 1134 of
> IBCustomDataSet, which is
> "           Result := ValidUTF8String(TextToSingleLine(Result))"
> The error message was "Identifier not found, ValidUTF8String".

Where did you find IBCustomDataSet? I don't find it in FPC or Lazarus sources.
ValidUTF8String was deprecated in Lazarus 1.7, then removed in 1.9 and thus 2.0.
This is part of the normal deprecation / removal cycle, not related to
using SVN.

Is there ValidUTF8String in Delphi? In that case it should be restored
preferably into the same unit Delphi has it.
Again this is not related to using SVN.


More information about the Lazarus mailing list