[Lazarus] Built console app on Linux, but won't run on another Linux machine

Bo Berglund bo.berglund at gmail.com
Sat Oct 27 13:58:16 CEST 2018

On Sat, 27 Oct 2018 13:39:12 +0200, Sven Barth via Lazarus
<lazarus at lists.lazarus-ide.org> wrote:

>Binaries usually have aligned sections so removing or adding just a 
>small bit (like the dependency on gdk in your case introduced by the 
>LCL) does not necessarily mean a change in size.
>You could also try "objdump -x /path/to/your/binary" and look at was is 
>listed as NEEDED in the Dynamic Section. You'd then need to find out 
>what dependencies you don't want to have and then figure out which units 
>led to their inclusion. Maybe it's just a stray unit that pulls in some 
>GUI dependencies.

I tried to upgrade, dist-upgrade the server to remove the logon
greeting about available updates then rebooted.
No difference.

Then I tried by installing xfce4 desktop, thinking that this would
deposit the X11 stuff into the system. But it did not solve the
problem even though the start error message now changed to:

(LicMgr:19268): Gtk-WARNING **: cannot open display:

So clearly there was a problem somewhere here concerning X11 and it is
gone, but replaced with this display stuff...

I *really* need to get this program running without any GUI references
since it is supposed to be run by cron every 10 minutes to process
website generated request emails...
And the server itself is never accessed except via the command line
over the network. I am currently some 8400 km away from the physical
location of the server....

Bo Berglund
Developer in Sweden

More information about the Lazarus mailing list