[Lazarus] Entering comment char { } not working in code window

Bo Berglund bo.berglund at gmail.com
Mon Oct 29 22:11:08 CET 2018

On Mon, 29 Oct 2018 19:34:43 +0100, Bo Berglund via Lazarus
<lazarus at lists.lazarus-ide.org> wrote:

>Is this a known issue?
>In Lazarus 1.8.4 FPC 3.0.4 on Ubuntu 18.04 LTS with xfce desktop and
>using a Swedish keyboard. Ubuntu is running in a VMWare PRO12 virtual
>In the code window I cannot enter regular pascal comments delimited by
>{ and }.

Turns out that ALL such escaped chars do not work, sometimes the code
editor jumps to a different tab or otherwise relocates focus and
sometimes nothing at all happens....
I googled and finally found an old forum entry where it was stated
that Ubuntu was to blame and that one could try the Keyboard setting
in the desktop.

I changed keyboard layout settings from "use system defaults" to
Swedish layout and set the keyboard to "Generic 105-key PC (intl.)"

Then the code editor also started to recognize the escaped characters

The strange thing is that all other applications I have tested
(terminal, Text Editor etc) worked fine even before I changed the
settings, and inside Lazarus all other places than Code Editor also
worked OK.
So there is something special about Code Editor, it seems like.

Anyway I seem to be able to type @{[]}\~ now, did not work before.

Bo Berglund
Developer in Sweden

More information about the Lazarus mailing list