[Lazarus] Lazarus 2 Installation under Raspbian Stretch fails

Bo Berglund bo.berglund at gmail.com
Mon Feb 11 18:04:39 CET 2019

On Sat, 9 Feb 2019 20:31:56 +0100, Joe via lazarus
<lazarus at lists.lazarus-ide.org> wrote:

>on a Pi 3B+ under Stretch I did this:
>~ $ mkdir lazarus-2a
>sudo chmod a+w lazarus-2a
>svn co https://svn.freepascal.org/svn/lazarus/trunk lazarus-2a
>cd lazarus-2a
>make clean all
>I get this error message:
>Compiling fcllaz
>home/pi/lazarus-2a/packager/registration/fcllaz.pas(11,3)  Fatal: 
>(10022) Can't find unit db used by fcllaz
>Fatal: (1018) Compilation aborted
>What's wrong?
>BTW: fpc -iW returns "3.0.4".

I have created a script file to use for installing fpc + lazarus on
RPi platforms including the dependencies and build tools. I have used
it many times on pristine RPi builds and it always worked fine for FPC
3.0.0 to 3.0.4 and Lazarus 1.6 to 1.8.x
I have put the script on my website for simplicity (so I can wget it
into a new RPi easily).

After reading this post I puilled out an RPi3 unit I had used for
other stuff so there was no old fpc/lazarus files on it and it was
running stretch too.

So this is what I did:
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade

Then I manually created the user bin dir at /home/pi/bin since this is
where my script deposits the binaries. I also logged out and back in
to make sure this bin dir was recognized as the user's bin and was on

I then created a ~/dev dir for my tools and downloaded my build script
into it using wget and configured the script regarding versions so
that fpc 3.0.4 and lazarus 2.0.0 would be the targets for

What happened when I ran the script is that it seemed to go OK as far
as all dependencies, subversion etc being installed and fpc 3.0.4
compiled and set up for use.
But the last steps where lazarus was to be installed ended after 37
minutes total with this message:

(9009) Assembling sourceeditor
sourceeditor.pp(11384) Error: (9008) Can't call the assembler, error
-1 switching to external assembling
sourceeditor.pp(11384) Fatal: (10026) There were 2 errors compiling
module, stopping
Fatal: (1018) Compilation aborted
Makefile:4144: recipe for target 'lazarus' failed
make[2]: *** [lazarus] Error 1
make[2]: Leaving directory '/home/pi/dev/lazarus/2.0.0/ide'
Makefile:4576: recipe for target 'bigide' failed
make[1]: *** [bigide] Error 2
make[1]: Leaving directory '/home/pi/dev/lazarus/2.0.0/ide'
Makefile:3378: recipe for target 'idebig' failed
make: *** [idebig] Error 2
install_lazfpc_local_pi.sh: 174: Cannot make Lazarus bigide! Aborting

I wonder at what step you are getting the missing db error?

And of course I wonder what was the reason for my failure?

Bo Berglund
Developer in Sweden

More information about the lazarus mailing list