[Lazarus] Lazarus 2 Installation under Raspbian Stretch fails

Bo Berglund bo.berglund at gmail.com
Mon Feb 11 19:39:04 CET 2019

On Mon, 11 Feb 2019 18:04:39 +0100, Bo Berglund via lazarus
<lazarus at lists.lazarus-ide.org> wrote:

>What happened when I ran the script is that it seemed to go OK as far
>as all dependencies, subversion etc being installed and fpc 3.0.4
>compiled and set up for use.
>But the last steps where lazarus was to be installed ended after 37
>minutes total with this message:
>(9009) Assembling sourceeditor
>sourceeditor.pp(11384) Error: (9008) Can't call the assembler, error
>-1 switching to external assembling
>sourceeditor.pp(11384) Fatal: (10026) There were 2 errors compiling
>module, stopping
>Fatal: (1018) Compilation aborted
>Makefile:4144: recipe for target 'lazarus' failed
>make[2]: *** [lazarus] Error 1
>make[2]: Leaving directory '/home/pi/dev/lazarus/2.0.0/ide'
>Makefile:4576: recipe for target 'bigide' failed
>make[1]: *** [bigide] Error 2
>make[1]: Leaving directory '/home/pi/dev/lazarus/2.0.0/ide'
>Makefile:3378: recipe for target 'idebig' failed
>make: *** [idebig] Error 2
>install_lazfpc_local_pi.sh: 174: Cannot make Lazarus bigide! Aborting

>And of course I wonder what was the reason for my failure?

I found the problem!
Swap size had not been increased on this RPi3 image!
After changing to 1024M swap I ran my lazarus-only install script (it
is a cut-down version of the original script) and it finished OK after
13 min and the Stretch menu was updated to include Lazarus 2.0.0 in
its Programming section.

All is well and good, so I am not able to help the OP with any other
advice but making sure his swap is set to 1024 MB.

Bo Berglund
Developer in Sweden

More information about the lazarus mailing list