[Lazarus] Keyboard mapping probelm

Brian b_lists at patandbrian.org
Wed May 6 02:19:57 CEST 2020

On 5/5/20 8:16 PM, Brian via lazarus wrote:
> On 5/5/20 7:57 PM, wkitty42--- via lazarus wrote:
>> On 5/5/20 6:00 PM, Brian via lazarus wrote:
>>> To save some trial and error, can anybody tell me which was the last
>>> version of Lazarus (for Linux, if that makes a difference) that
>>> doesn't exhibit the problem of an 'm' producing a line feed and an 'i'
>>> producing a tab then an 'i'?
>> check your key map settings in lazarus configuration... it sounds like
>> a macro or you have configured 'm' to line feed and 'i' to tab-'i'...
> I will look (again), but this is happening reproducibly on a totally
> clean build of trunk (via fpcupdeluxe), I have tried rebuilding
> Lazarus with clean all and *just once* I got things to work again
> using qt5. I've never managed to get things to work again since. I
> have changed no key map settings, I have configured no macros. This is
> using 64-bit Linux Mint 19.3, should anybody feel that makes a
> difference, and BTW, I have also tried switching keyboards, with
> absolutely no effect. I had about 6-9 months away from using Lazarus,
> during that time I changed from using Ubuntu 18.04 LTS to Mint 19.3. I
> didn't see the problem on my old setup, it has occurred every time
> except that ONE occasion on the current setup. The same PC, just the
> operating system changed.

I forgot to add - I totally erased fpcup's entire tree and rebuilt
from scratch. No change.


More information about the lazarus mailing list