[Lazarus] Keyboard mapping probelm

Brian b_lists at patandbrian.org
Thu May 28 00:53:14 CEST 2020

On 5/20/20 8:37 AM, Brian via lazarus wrote:
> On 5/20/20 5:50 AM, John Landmesser via lazarus wrote:
>> Am 20.05.20 um 01:12 schrieb Brian via lazarus:
>>> Regrettably, it appears I spoke too soon. I fired up Lazarus again and
>>> the problem is back. I'm compiling trunk for both fpc and lazarus
>>> using fpcupdeluxe. To recap, this is under Linux Mint 19.3 64-bit
>>> (Ubuntu base). I have absolutely *NOT* done any keyboard remapping nor
>>> defined any macros since everything last worked correctly. The setup I
>>> have in a LMDE (Linux Mint Debian) virtual machine still works
>>> correctly.
>>> I will update both setups, so that I know I am (should be!) running
>>> exactly the same versions of trunk, and report back in due course.
>>> Brian.
>> Perhaps try another version of fpcupdeluxe?
>> https://github.com/LongDirtyAnimAlf/fpcupdeluxe/releases
> I downloaded the latest as then was for linux on x86_64. I see there
> has been another release since I wrote my post. I'll give it a try. I
> guess I could also try the qt5 version.

OK, my last word on this subject. I can only conclude that there is
some kind of goofy multi-way interaction going on between Lazarus and
other programs. I have tried multiple versions of Lazarus, using both
the gtk2 and qt5 versions of fpcupdeluxe. In all cases, I saw the i ->
tab & i and m -> newline. I do NOT see this on the Debian-based
version of Mint running in a virtual machine, and I also set up
another VM with the same Ubuntu-based version of Mint (19.3 64-bit) as
I have on the host. Neither VM showed the problem with Lazarus!

The final straw is that I just set up a new PC for my wife, again
Ubuntu Mint 19.3, and out of curiosity, I installed Lazarus. The keys
worked fine.

I have no idea what is going on. I reiterate that I have removed all
config files, using the combination of wkitty42's commandline magic
*and* my kfinds, and that I have done absolutely no key remapping nor
macro defining. Twice, and ONLY twice, I have had the problem go away
after a rebuild of FPC and Lazarus, but rebooting the PC brought the
problem back again.

I've given up. I have wasted enough time on trying to sort this
problem. At least as long as it all works, I will just use Lazarus in
a VM, and transfer the completed source files to my host machine for a
final compilation.


More information about the lazarus mailing list