[Lazarus] Clipboard Data Goes Away

Bo Berglund bo.berglund at gmail.com
Fri Apr 2 10:55:21 CEST 2021

On Fri, 02 Apr 2021 10:08:20 +0200, Marc Weustink via lazarus
<lazarus at lists.lazarus-ide.org> wrote:

>Just s general warning, it doesn't say anything about your observations.
>Be careful with drawing conclusions when using vnc. The past year I've been working remote and I'm using vnc to access my desktop at work. Transferring clipboard data most times work, but sometimes it is a pain. It won't copy or paste the right selection. Reconnecting vnc usually solves the issue.
>This is independent of the source or target application.
>So the issue you observed might be caused by vnc or it might be indeed an issue in Lazarus

Just as a test with Lazarus on Windows I repeated the sequences I described when
copying the same text as before on Windows (in Notepad++) and then using Ctrl-F
or F3 inside Lazarus on Windows in order to start a new search.
The search dialog was showing a nonrelated search string but Ctrl-V worked just
fine to replace it with my copied text.

Here of course VNC is not involved and all operations happened in Windows.

So I now went into the VNC session on Linux and there I opened a text editor in
addition to Lazarus.
I entered text into the text editor and then coped one word there.

Back into Lazarus (still in Linux) I used both Ctrl-F and F3 to start search
dialogs and in both cases there was an unrelated search term coming up, but also
in both cases using Ctrl-V to paste my previously copied text worked fine!

So I must concur with your observation that this case is a VNC clipboard issue!
Good to know, but disturbing nevertheless...

Now I remember having read that Linux has more than one clipboard, possibly VNC
is using the "wrong" one?

But it still works when just copying text from Windows and pasting it directly
into the Lazarus code editor in Linux...

Just not into the search dialog.

Bo Berglund
Developer in Sweden

More information about the lazarus mailing list