[Lazarus] Strange linker messages "undefined reference" when building on RPi4 - CompileLog_2022-04-15.log (0/1)

Bo Berglund bo.berglund at gmail.com
Wed Apr 19 18:24:21 CEST 2023

On Mon, 17 Apr 2023 10:32:51 +0200, Mattias Gaertner via lazarus
<lazarus at lists.lazarus-ide.org> wrote:

>On Mon, 17 Apr 2023 10:11:28 +0200
>Giuliano Colla via lazarus <lazarus at lists.lazarus-ide.org> wrote:
>> Il 17/04/2023 08:15, Bo Berglund via lazarus ha scritto:
>> > You never stop learning!  
>> Another thing I have learned with experience, is that sometimes the 
>> cleanup isn't perfect and leaves some dangling ppu which creates a 
>> problem like the one you had. It occurred to me when attempting to 
>> rebuild Lazarus, and I was getting an unexpected "undefined
>> reference". 
>Can happen when some unit is moved to another package.
>> I was trying to build a normal IDE, so I tried to build a
>> "debug IDE" instead. With different compilation flags it was forced
>> to rebuild everything, and it worked fine. Then I tried again a
>> "normal IDE", and this time it went OK.
>That's why there is "Clean all" radiobutton on the configure build
>lazarus dialog. It building fails, try that.

Please can you describe where exactly I can find this on Lazarus 2.2.6?

I don't know where I find "Configure build", is it a project option or a global
settings (Below menu Project or Tools)?

If I look at the Run menu I see very far down "Configure Build+Run File...", but
that does not sound like what you are discussing, right?

Bo Berglund
Developer in Sweden

More information about the lazarus mailing list