[Lazarus] Strange linker messages "undefined reference" when building on RPi4 - CompileLog_2022-04-15.log (0/1)

Giuliano Colla giuliano.colla at fastwebnet.it
Thu Apr 20 00:10:07 CEST 2023

Il 19/04/2023 18:24, Bo Berglund via lazarus ha scritto:

> On Mon, 17 Apr 2023 10:32:51 +0200, Mattias Gaertner via lazarus
> <lazarus at lists.lazarus-ide.org> wrote:
>> On Mon, 17 Apr 2023 10:11:28 +0200
>> Giuliano Colla via lazarus <lazarus at lists.lazarus-ide.org> wrote:
>>> Il 17/04/2023 08:15, Bo Berglund via lazarus ha scritto:
>>>> You never stop learning!
>>> Another thing I have learned with experience, is that sometimes the
>>> cleanup isn't perfect and leaves some dangling ppu which creates a
>>> problem like the one you had. It occurred to me when attempting to
>>> rebuild Lazarus, and I was getting an unexpected "undefined
>>> reference".
>> Can happen when some unit is moved to another package.
>>> I was trying to build a normal IDE, so I tried to build a
>>> "debug IDE" instead. With different compilation flags it was forced
>>> to rebuild everything, and it worked fine. Then I tried again a
>>> "normal IDE", and this time it went OK.
>> That's why there is "Clean all" radiobutton on the configure build
>> lazarus dialog. It building fails, try that.
> Please can you describe where exactly I can find this on Lazarus 2.2.6?
> I don't know where I find "Configure build", is it a project option or a global
> settings (Below menu Project or Tools)?
> If I look at the Run menu I see very far down "Configure Build+Run File...", but
> that does not sound like what you are discussing, right?

It is under Tools. The last two line are about rebuilding Lazarus and 
changing the build options (different widgetset, different modes, etc.)
The Run menu contains just options for the current project. No relation 
with rebuilding Lazarus.


Do not do to others as you would have them do to you.They might have different tastes.

More information about the lazarus mailing list