[Qt] Free Pascal Qt4 binding not working with QT 4.7.0

Wagner Okuda Campaneli wagnerokuda at gmail.com
Tue Nov 16 17:04:04 CET 2010

Here's the console output I forgot:

wagner at wagner-Virtual-Machine:~/Desktop/qt4pas-V2.1_Qt4.5.3$ qmake
Project MESSAGE: This pascal binding should be used for 4.5.3 and current Qt
is 4.7.0
Project MESSAGE: Pascal Qt Interface for binding platform: BINUX
Project MESSAGE: Install location: /usr/lib
wagner at wagner-Virtual-Machine:~/Desktop/qt4pas-V2.1_Qt4.5.3$ make
-I/usr/share/qt4/mkspecs/linux-g++ -I. -I/usr/include/qt4/QtCore
-I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtGui
-I/usr/include/qt4/QtWebKit -I/usr/include/qt4 -Itmp -o tmp/qt4pas.o
In file included from src/qt4pas.cpp:14:
src/pascalbind.h:16: fatal error: QtCore: File or directory not found
compilation terminated.
make: ** [tmp/qt4pas.o] Erro 1

My gcc version is 4.4.5
Thanks again

2010/11/16 Wagner Okuda Campaneli <wagnerokuda at gmail.com>

> Hi everyone,
> I've downloaded the binding's library source (V2.1, Qt 4.5.X, compatible
> with Qt 4.6.X) expecting that it would work with Qt 4.7, but when I tried to
> compile it, some problems appeared.
> When I used the qmake, this message showed up:
> "This Pascal binding should be used for 4.5.3 and current Qt is 4.7.0"
> It didn"t concern me so much, 'cause the makefile was created. But when I
> tried to *make *it, it said that the QtCore was not found.
> Does anyone know what the problem could be?
> Any help would be appreciated.
> Thanks
> Wagner
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.lazarus-ide.org/pipermail/qt/attachments/20101116/04a7c0cf/attachment-0002.html>

More information about the Qt mailing list