[lazarus] Control not found

Matthew Bradford mbradford at bahaigear.com
Mon May 20 12:32:06 EDT 2002

   Yes, that is the issue I have been having: "Fatal: Can't find unit 
CONTROLS".  Sorry I didn't put that in the original message it was late 
and I thought I had.  The issue here is that even if I put the units in 
the same directory as my project it still fails.  I've not put in the 
source, but should I really need to do that for a "hello world" app? 
 Does the zip file on the website work?  Actually it seems more like an 
issue with the fpc.cfg file (or fpc's inability to look for something in 
any new directories.)

Actually.. now I think about it.  I even tried putting the things into 
another directory I KNEW was working properly. (where CRT is at) and it 
STILL gave me the same error.

Any ideas?
 - Matt

Mattias Gaertner wrote:

>I'm not quite sure what you mean with "Control not found". Perhaps you mean "Fatal: Can't find unit CONTROLS" ?
>Anyway, I suggest, to use the installation in /usr/local only for dry running LCL applications. To use the IDE you should take a cvs snapshot and use 'make clean all'. Leave the sources and the lazarus binary where they are. You can do that as any user.
>If you want a multiuser installation, install the cvs to a directory, where everyone has read perms and link the lazarus binary to /usr/local/bin/lazarus.
>     To unsubscribe: mail lazarus-request at miraclec.com with
>                "unsubscribe" as the Subject
>    archives at http://www.miraclec.com/list_archives/lazarus

More information about the Lazarus mailing list