[lazarus] Problems on Fedora with Lazarus

Mattias Gaertner nc-gaertnma at netcologne.de
Sat Nov 8 07:35:20 EST 2003

On 08 Nov 2003 13:31:33 +0100
John The Ripper <ripper at arsis.net> wrote:

> Just yesterday I installed Fedora and find it very surprising that for
> the first time in my life Lazarus doesn't work. It just throws out
> without even showing any Window, with exception "out of memory" to
> console

Sounds like an endless loop.

> After that I tried with fpc 1.9, same result except MessageBox "Out of
> Memory" showed up.

Can you start it with gdb and send a backtrace?


> I even recompiled fpc 1.0.10 if some libraries would be mismatched in
> binary, but there was the same result as before.
> Now I'm stuck with a real problem. If there's no solution I would have
> to abandon one of those two. But problem is that Fedora is just to great
> to go back, as snappy Linux as Fedora is, well it reminds people on
> times when user interfaces were simple, light fast and responsive as
> possible. Difference in speed to RH9 I was using before is impossible to
> compare.
> Well, fact is that not having Fedora on my notebook is not really hard
> to imagine, all it would need it would be to stop coding during my
> breaks and when I'm not at home. But as it seems Fedora as good as it is
> will probably sooner gain than loose people. At least those who missed
> apt and other goodies.
> I'm not an expert but that maybe a clue. There are 3 major differences
> between RH9 and Fedora.
> 1. nptl threads
> 2. Prelinking: From an end user perspective, it will make applications
> load faster, as dynamicly linked libraries will be loaded ahead of time
> into unused memory.
> 3. Exec-Shield: Exec-shield purports to randomize VM addresses and make
> parts of applications (as well as their stack) non-executable. Think of
> it as "damage control" for security holes. The integrated stack
> protection (that the Exec-shield kernel addition replaces/includes) is
> very important for foiling buffer overflow attacks
> Funny thing is, all other software RH9 rpms that I tried are working as
> they should, out of src.rpm or rpm. 
> btw. lazarus was tried only by compiling from 4 different cvs versions
> (1 from yesterday and 3 versions which were working perfectly on RH9)
> which I found on my disk.
> I don't know if that helped anything but here it is anyway
> ^^
> _________________________________________________________________
>      To unsubscribe: mail lazarus-request at miraclec.com with
>                 "unsubscribe" as the Subject
>    archives at http://www.lazarus.freepascal.org/mailarchives


More information about the Lazarus mailing list